System-wide outage
Incident Report for Apify
Resolved
The issue is resolved, all systems are operational. We're taking further measures to prevent similar incidents in the future. The root cause of the issue was a database index change that overutilized its replicas. In order to prevent these problems in the future, we are implementing a smoother way to realize these changes in a safer way.
Posted May 19, 2022 - 17:43 CEST
Monitoring
All services are operating within normal parameters. We'll keep monitoring our database for a while, before closing the incident.
Posted May 19, 2022 - 14:51 CEST
Update
We have identified an issue and are starting to see recovery across all services, however actor service is still underperforming.
Posted May 19, 2022 - 14:35 CEST
Update
We are continuing to investigate this issue.
Posted May 19, 2022 - 14:33 CEST
Update
We are continuing to investigate this issue.
Posted May 19, 2022 - 14:25 CEST
Investigating
We are currently experiencing an issues with our main database, which causes system-wide outage. We are investigating the issue.
Posted May 19, 2022 - 14:25 CEST
This incident affected: Proxy (Datacenter) and Console (console.apify.com), API (api.apify.com), Actors, Scheduler, Webhooks.