A fix has been implemented, and we are back to the usual performance.
Posted Jan 17, 2025 - 11:42 CET
Update
We have identified the problem and are working towards fixing the performance. For now, we will keep experiencing more retries and degraded performance.
Posted Jan 17, 2025 - 10:03 CET
Update
We are continuing to work on a fix for this issue.
Posted Jan 17, 2025 - 08:56 CET
Identified
SERP proxies' performance has degraded because of problems with external data providers. We are working on a fix to restore the success rate to its original level.