Degraded performance of Google SERP Proxy

Incident Report for Apify

Resolved

The Google SERP Proxy is stabilized, and we continue to monitor its performance.
Posted Aug 05, 2026 - 15:30 CEST

Identified

The Google SERP proxy is working, but with slower-than-usual response times. We continue to investigate the issue.
Posted Aug 04, 2026 - 13:05 CEST

Update

The Google SERP Proxy is not processing almost any requests or is very slow. We're investigating the issue.
Posted Aug 04, 2026 - 02:43 CEST

Investigating

We are experiencing slow requests handling for Google SERP proxy. We're investigating the issue.
Posted Aug 04, 2026 - 01:56 CEST
This incident affected: Proxy (SERP).