The incident has been resolved and SERP is fully functional again.
Posted Mar 06, 2025 - 14:52 CET
Monitoring
A fix has been implemented to channel most of the traffic through the most reliable proxy providers.
However, results for the shopping tab might still return content in unexpected languages due to a geolocation issue. We're aware of this and are working on a solution.
Posted Mar 06, 2025 - 03:39 CET
Identified
The incident is caused by issues with our proxy providers. We are actively working with them to resolve the issue and will provide updates as soon as we have more information.