Degraded Actor runs performance

Incident Report for Apify

Resolved

As of 07:30 UTC, the Apify platform is operating normally. Amazon Web Services have also marked their incident as resolved, which gives us confidence that the outage has concluded. We will continue to monitor the situation and apologize for any inconvenience this may have caused.
Posted Oct 21, 2025 - 09:30 CEST

Monitoring

We can confirm AWS is slowly recovering to a normal state.

We have been able to recover all the Apify services fully and as the last step we turned scheduler back on. As this was a second disruption within a day we will keep monitoring the situation over night.

We will identify and take steps to improve the reaction next time, however we can't ensure Apify platform staying fully operational when underlying provider (AWS) experiences complete outage.
Posted Oct 21, 2025 - 00:43 CEST

Update

We can confirm AWS is slowly recovering to a normal state.

We have been able to recover all the Apify services fully and as the last step we turned scheduler back on. As this was a second disruption within a day we will keep monitoring the situation over night.

We will identify and take steps to improve the reaction next time, however we can't ensure Apify platform staying fully operational when underlying provider (AWS) experiences complete outage.
Posted Oct 21, 2025 - 00:40 CEST

Update

We're seeing slow recovery across our systems from the global AWS outage. You should be able to run your Actors but schedules remain non-operational.
Posted Oct 20, 2025 - 22:59 CEST

Update

We are experiencing a significant disruption in running Actors due to an ongoing upstream issue with AWS EC2. Our team is actively monitoring the situation and will restore full service as soon as possible. The integrity of the data on the platform has not been compromised.
Posted Oct 20, 2025 - 18:16 CEST

Update

The upstream issue with AWS EC2 is ongoing, resulting in significant degradation of Actor performance. We are closely monitoring the situation and implementing a limited set of mitigation measures where possible. Further updates will be provided as they become available.
Posted Oct 20, 2025 - 17:51 CEST

Identified

We're experiencing degraded performance in Actor runs due an upstream issue with AWS EC2.

See: AWS Status Page https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 16:42 CEST
This incident affected: Actors and Scheduler.