We have seen a full recovery of the SERP proxy success rates. We will continue monitoring for any future degradation.
Posted Aug 08, 2026 - 16:15 CEST
Update
The success rate and latency is continuing to improve to almost normal levels, we expect full recovery soon.
Posted Aug 08, 2026 - 15:36 CEST
Update
We have applied partial fixes to improve the situation and lower the error rate. We are still seeing an elevated error rate and are continuing to work on reaching a full resolution.
Posted Aug 08, 2026 - 08:15 CEST
Identified
The performance problems are caused by issues with our upstream providers. We are in contact with them to find a solution.
Posted Aug 08, 2026 - 01:00 CEST
Investigating
The Google SERP proxy is experiencing increased response times and elevated error rates. We are investigating the issue.