Platform outage

Incident Report for Apify

Resolved

All systems are operational, and we apologize for any inconvenience this might have caused. We are currently implementing new measures to make sure that this won't happen again.
Posted Oct 20, 2025 - 16:40 CEST

Monitoring

The upstream AWS issue is recovering, and we’re seeing full recovery across all our systems.

Between 07:00–09:30 UTC, no Actor runs were executed. There was no data loss, but Actor runs during this window did not start as expected, or they may have timed out or failed. Actor schedules resumed operation at 10:00 UTC.

Unfortunately, we were unable to update this status page earlier due to statuspage.io not working as well. In addition, Intercom, our customer support chat provider, was also experiencing an outage at the same time, which limited our ability to communicate in real-time.

We’re deeply sorry for the lack of timely communication and the disruption this caused. We’re already reviewing our communication and redundancy processes to ensure we can keep you better informed during future incidents, even when multiple systems are affected.

Thank you for your patience and understanding.
Posted Oct 20, 2025 - 11:54 CEST

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:30 CEST

Identified

We are currently experiencing issues accessing and using our services across the entire system. The issue originates from AWS (see: AWS Status Page https://health.aws.amazon.com/health/status). We are actively investigating and will provide updates as soon as possible.
Posted Oct 20, 2025 - 09:00 CEST
This incident affected: Web (apify.com), Console (console.apify.com), API (api.apify.com), Actors, Scheduler, Webhooks, Docs (docs.apify.com), MCP server (mcp.apify.com), External services (AWS EC2, AWS S3, AWS SQS, AWS elb-us-east-1, AWS elasticache-us-east-1, AWS dynamodb-us-east-1, Braintree Payment Gateway API, Braintree Canadian Processing, Braintree APAC Processing, Braintree European Processing, Braintree United States Processing, npm, Inc. Registry Reads, Braintree 3D Secure, AWS ecr-us-east-1, AWS eks-us-east-1), Proxy (Datacenter, Residential, SERP), and Storage (Dataset, Request queue, Key-value store).