Bug in Get Dataset Items API endpoint
Incident Report for Apify
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 13:14 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 08, 2019 - 10:10 CET
Identified
We've discovered that yesterday's deploy introduced a bug into the Get Dataset Items API endpoint, which caused an infinite loop in the Dataset.map() and Dataset.forEach() functions in Apify SDK. Consequently, actors that depend on this feature might have time out.

We're rolling back the previous version.
Posted Nov 08, 2019 - 10:10 CET
This incident affected: API (api.apify.com).