degraded performance on our API

Incident Report for Apify

Resolved

All systems are operational now.

Between 1:00 a.m. and 2:00 a.m. (CET), we experienced a high load on our platform, which may have led to degraded performance and slowed down our services during that timeframe.

The error caused a data duplication resulting in a ~30 of users being overcharged by 10 USD on average, and some of the storage and run statistics were duplicated. The underlying issue has been addressed and we’ll be contacting and refunding the impacted users.
Posted Jun 03, 2025 - 07:21 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 02:42 CEST

Identified

Performance has recovered, and we are investigating the root cause.
Posted Jun 03, 2025 - 02:30 CEST

Investigating

We're experiencing degraded performance on our API due to an increase in load on the API. We're investigating the problem.
Posted Jun 03, 2025 - 02:16 CEST
This incident affected: API (api.apify.com).