Google SERP proxies
Incident Report for Apify
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 14:51 CET
Investigating
Google SERP proxy may experiencing outage. We're currently investigating an issue.
Posted Jan 16, 2025 - 14:47 CET
This incident affected: Proxy (SERP).