We are continuing to monitor for any further issues.
Posted Jan 27, 2026 - 10:33 CET
Monitoring
The issue has been identified and a fix has been implemented. We are monitoring the system for further issues.
Posted Jan 27, 2026 - 06:45 CET
Investigating
We are currently investigating an issue affecting residential proxies. Some requests are failing or timing out. Our team is actively working to identify the root cause and restore normal operation. Further updates will be provided as we learn more.