Google SERP proxy has increased response times

Incident Report for Apify

Resolved

We have implemented a fix, and the response time has been recovering since 09:30 UTC. As of 10:30 UTC, the response time has returned to normal. We will continue to monitor the response time. We apologize for any inconvenience caused.
Posted Mar 16, 2025 - 11:55 CET

Identified

Since 00:10 UTC, the Google SERP proxy has experienced increased response times. This may cause requests using the proxy to time out. As a temporary workaround, we recommend increasing the request timeout. We apologize for any inconvenience and are working toward a swift resolution.
Posted Mar 16, 2025 - 02:46 CET
This incident affected: Proxy (SERP).