System outage
Incident Report for Apify
Resolved
The incident has been resolved. It was caused by a bug with database updates under high load.

Between 7:30 UTC and 8:10 UTC, the Apify platform was overloaded, and most operations were timing out or failing. This includes API calls, running Actors, proxy requests, or accessing the Console.

There has been no data loss. Scheduled Actors were executed with a delay once the platform recovered. The dates of last modifications of request queues might not be fully up-to-date.
Posted Nov 27, 2024 - 10:42 CET
Monitoring
A fix has been implemented and the platform is recovering. We will do an analysis of the impact and determine the appropriate remediation.
Posted Nov 27, 2024 - 09:10 CET
Investigating
Due to an internal database issue, the whole platform is overloaded, and most requests are failing.
Posted Nov 27, 2024 - 08:38 CET
This incident affected: Proxy (Datacenter, Residential, SERP), Storage (Dataset, Request queue, Key-value store), and Console (console.apify.com), API (api.apify.com), Actors, Scheduler, Webhooks.