Degraded SERP performance

Incident Report for Apify

Resolved

The issue has been resolved.
Both the response time and success rate have returned to normal levels.
Posted Jul 17, 2026 - 22:08 CEST

Investigating

We're seeing degraded performance of Google SERP requests. Responses may take longer than usual. We're investigating the issue.
Posted Jul 17, 2026 - 16:04 CEST
This incident affected: Proxy (SERP).